Україна - єдина країна. Донецьк - це Україна!
  
 
     
 
 
Inco-Systems
 
   
 
   
 
 

Комментарии

При настройке обмена данными между 1С 8 Бухгалтерия Предприятия и Управление Торговлей для Украины возникла проблема, связанная с тем, что исходящие платежные поручения не экспортируются из 1с-бухгалтерии в торговлю.
Как выяснилось, не происходил экспорт Исходящих платежных поручений по причине несоответствия типа реального номера поручения.

Дело в том, что платежи велись в Приват24, а в бухгалтерию импортировались уже сформированные документы по расчетному счету Приватбанка. Импорт производился с помощью обработки, предоставленной самим банком. Приватбанк берет оплату за каждый исходящий платеж и формирует исходящие платежки в свою пользу автоматически. Номера платежек, сформированных банком, содержаи кроме цифр буквы и спецсимволы.

Теперь вернемся к 1С-ке : в бухгалтерии поле номера платежки имеет тип "Строка" и номера успешно сохранялись. А в конфигурации"Управление торговлей" номер исходящего поручения числовой, поэтому и возникали ошибки.

Конечно, после импорта банковских выписок, можно руками удалять в Исходящих ПП номер поручения или хотя бы убрать из номера буквы, но при регулярной работе это создает дополнительные сложности.

Решение ниже предназначено для тех, кто занимается поддержкой конфигураций: специалисты поймут, бухгалтеры и неспециалисты обращайтесь - договоримся, недорого.

Для решения проблемы достаточно в правила обмена "Исходящего поручения" в описателе свойств поля "Номер поручения" заменить существующий код на этот:

<ПередВыгрузкой>Если ЗначениеЗаполнено(Источник.НомерПоручения) Тогда
    ВхСтрока = СокрП(Источник.НомерПоручения);
       НовСтрока = "";
    ПравильныеСимволы = "0123456789";
    Для Сч = 1 по СтрДлина(ВхСтрока) Цикл
        ТекСимв = Сред(ВхСтрока, Сч, 1);
        Если Найти(ПравильныеСимволы, ТекСимв) &gt; 0 Тогда
            НовСтрока = НовСтрока + ТекСимв;
           КонецЕсли;
    КонецЦикла;
    Значение = НовСтрока;
Иначе
    Пусто = Истина
КонецЕсли;</ПередВыгрузкой>

Код удаляет из номера поручения все знаки кроме цифр в момент экспорта данных в торговлю, при этом в бухгалтерии данные номера платежки остаются неизменными.

1 1 1 1 1 1 1 1 1 1 Рейтинг 0.00 [0 Голоса (ов)]

Добавить комментарий

Запрещено:
  1. Спамить, флудить
  2. Ругаться, оскорблять собеседников
  3. Писать НЕ по теме статьи
  4. Указывать ссылки на другие сайты, не относящиеся к теме обсуждения.
Защитный код
Обновить

Интересно? Сделай закладку!

Отправить в DeliciousОтправить в DiggОтправить в FacebookОтправить в Google BookmarksОтправить в TechnoratiОтправить в TwitterОтправить в LinkedInОтправить в BobrdobrОтправить в LiveinternetОтправить в Livejournal

Ищем клиентов - организации или предпринимателей, которым необходима: помощь в работе с бухгалтерскими программами 1С 7 и 8, OPZ, Sonata, Taxer, FreeZvit, Medoc и другие.

Выполняемые работы : Установка, настройка, обновление программ, обучение пользователей, администрирование сети, управление сервером.

Интернет-проекты : настройка и наполнение сайтов на площдках PROM.UA, Zakupka.com, WordPress, другие работы, связанные с  продвижением сайтов. Выполняем удаленное управление и решение всех вопросов по телефону, скайпу.

Оставляйте заявки и вопросы через "Контакты".


Реклама

 
 

© Права на сайт inco-systems.com.ua и все материалы* принадлежат ООО "Инко-Системы" - 2010-2018. Копирование любых материалов не допускается без разрешения Владельца.